Fork me on GitHub

Installation


La librairie Jaxon est distribuée sous forme de packages Composer.

Pour l'installer, il faut ajouter la ligne suivante dans le fichier composer.json.

"require": {
    "jaxon-php/jaxon-core": "~3.0"
}

Ou bien exécuter la commande

composer require jaxon-php/jaxon-core:~3.0

La librairie javascript

Jaxon nécessite pour son fonctionnement d'inclure sa librairie javascript jaxon-js dans le code HTML.

Par défaut, la librairie PHP charge les fichiers javascript à partir du CDN jsDelivr.

Il est enfin possible de les installer sur un serveur privé, auquel cas il faut mettre à jour l'option de configuration js.lib.uri.